Error Report

From RadiWiki
(Redirected from RadiLog)
Jump to: navigation, search

An issue could be a bug or something that is not working correctly, or working differently then expected. The goal of the error report procedure is to accomplish quick and effective support service. In general, a new problem (or issue) can only be solved if our RadiMation® support team will be able to reproduce the problem. The issue report procedure is intended to store and provide all relevant information that is needed to investigate and reproduce the issue.

RadiMation® incorporates the RadiLog automatic logging tool which is automatically running in background and captures all communication. In case of a problematic event, all relevant information can be transferred to the RadiMation® support team by pressing the Report button when there is an error. This form can also be accessed manually. It is of course also possible to send us any question directly by e-mailing us at support@radimation.com.

Upon receipt of a new reported issue the RadiMation® support team will provide a unique issue number (#xxxxx). This reference number should be used during all further communication in relation to the specific issue.

Reporting a problem when an error is shown

When an error is shown within RadiMation®, the error can be directly reported to the RadiMation® support team.

  1. On the RadiMation® Error Window, press the Report button.
    ErrorPopupWindow.png
  2. The Error Report window will be shown.
    ReportErrorWindow.png
  3. Fill in all the additional information like requested. As seen in the screenshot, you must check the I agree that my provided data is used to improve the products and services of DARE!! checkbox.
  4. Check if you have filled all boxes. If not all boxes are filled you can not send or save the file. When information is missing a red circle with a cross is displayed. If you hover over it with your mouse it will tell you what is missing in the form.
  5. Once the report information is filled in the buttons change colour, the report can now be send to the RadiMation® support team in 2 ways:
    • Send the report automatically using the Send button.
    • Save the report with the Save button, and send the file over email to support@radimation.com

The report automatically contains a log of all the recent communication with the test and measurement equipment. That information is very helpful and valuable to be able to resolve your issue.

Manually reporting an issue

If you would like to report a problem with RadiMation® without a RadiMation® error, you can also open the Error Report window from the Help menu:

   Menu.png Help
      Menu.png Report Error

.

ManualReportMenu.png

Also if a test is already running, and you would like to report an error related to the running test, but no Error Report window is shown, then it is still possible to use this Help menu. The generated Error Report will then still contain the communication log of the running test.

Reporting a RadiLog communication file only

If for some reason the above reporting is not available, the communication log can also be reported manually. Please follow these instructions accordingly:

  1. Open the RadiMation® logging tool (RadiLog) from the View menu in RadiMation®
    ViewRadiLogMenu.png
  2. While the RadiLog tool is opened, reproduce the error.
  3. When the error has been logged, save the log file, by selecting 'File' and 'Save As...' from the menu.
    RadiLogSaveAs.png
  4. Send the .RadiLog file (zipped) to the RadiMation® support e-mail address support@radimation.com